Zusätzlich zu Code::Blocks ist ein C-Compiler erforderlich, der aber bei jeder Linux Version erhältlich ist. Je nach vorhandener Linux-Distribution kann der Compiler über Yast2 (SuSE Linux), adept (Debian, Ubuntu) oder ähnlichen Installationswerkzeugen installiert werden.

Bei manchen Linux-Distributionen ist Code::Blocks auch mit diesem Installationswerkzeug installierbar. Ist es dort nicht verfügbar, kann eine Version von www.codeblocks.org/downloads/binaries heruntergeladen und installiert werden.